К основному контенту

Weblogic Diagnostic Framework Run Bash Script (reboot managed server) - (bad practices)

Вообщем переодически сервер дохнет по: The WebLogic Server encountered a critical failure java.lang.OutOfMemoryError: Metaspace Reason: There is a panic condition in the server. The server is configured to exit on panic И хотя это гавно пишет типа  Reason: There is a panic condition in the server. The server is configured to exit on panic чёт ни хуя он ни куда не exit.... Вообщем т.к разбираться с тем чем он жрётся нет ни времени ни желания (оно обязательно появится)... как вариант можно приделать костыль... костыль будет заключаться в ребуте сервера при возникновении этой ошибки. Что значит для этого надо... Желания и понимание что так жить нельзя, и вообще... Делаем новый модуль называем скажем:  Reboot-OOMMetaSpace Идём в в новый модуль делаем Policy: Называем его OOM-Metaspace и говорит что это Server log: Жмём next в Configuration Policy пишем: log.logMessage.contains('java.lang.OutOfMemoryError: Metaspace'...

Oracle BI alternative authentication provider OVD(Oracle Virtual Directory)!

Вообщем адаптер AD уже есть и работает. BISystemUser существует исключительно в AD( ну и в OVD соответственно т.к типа мега join%)
Пользователей будем вытаскивать по sAMAccountName.

http://172.20.16.71:7001/console/ -> Security Realms -> myrealm -> Providers создаем новый:



Тут видны все основные настройки которые необходимо сделать.
Save -> Active Changes
После этого предалагаю перезапустить weblogic дабы посмотреть что пользователи и группы нормально подхватились из OVD адаптера.


Стопаем всё:



export ORACLE_INSTANCE=/ess/middleware/instances/bi_instance
/ess/middleware/instances/bi_instance/bin/opmnctl stopall
/ess/user_projects/domains/bifoundation_domain/bin/stopManagedWebLogic.sh bi_server1
/ess/user_projects/domains/bifoundation_domain/bin/stopWebLogic.sh
exit 0;

Запускаем только weblogic.



export ORACLE_INSTANCE=/ess/middleware/instances/bi_instance
export LOG_DIR=/home/oracle/Scripts/Logs
nohup /ess/user_projects/domains/bifoundation_domain/bin/startWebLogic.sh 1>$LOG_DIR/WLOut.txt 2>$LOG_DIR/WLErr.txt&


Удаляем на хрен AD ибо там теже пользователи что и в OVD поэтому ни фига не понятно от куда он их берёт , но weblogic утверждает что из AD ибо он в списке адаптеров первый.


Перезапускаем.


Итог: Работает (пользователи из OVD есть), нуууу ооочень медлено он их вытаскивает... хотя это же OVD.. Поэтому кнопку User and Groups рекомендуется нажимать пореже дабы не заснуть...


Далее надо запутить Farm и opmn естественно нормально они не запустятся ошибка следующая:

[2012-07-10T11:03:40.000+04:00] [OBIPS] [NOTIFICATION:1] [] [saw.sawserver] [ecid: ] [tid: ] Oracle BI Presentation Services (OBIPS) 11.1.1.6.0 (Build 120104.0800 64-bit) are starting up.[[
File:sawserver.cpp
Line:451
Location:
        saw.sawserver
ecid:  
]]
[2012-07-10T11:03:44.000+04:00] [OBIPS] [ERROR:1] [] [saw.security.odbcuserpopulationimpl.getbisystemconnection] [ecid: ] [tid: ] Authentication Failure.
Odbc driver returned an error (SQLDriverConnectW).
State: 08004.  Code: 10018.  [NQODBC] [SQL_STATE: 08004] [nQSError: 10018] Access for the requested connection is refused.
[nQSError: 43113] Message returned from OBIS.
[nQSError: 43126] Authentication failed: invalid user/password. (08004)[[
File:odbcuserpoploaderimpl.cpp
Line:995
Location:
        saw.security.odbcuserpopulationimpl.getbisystemconnection
        saw.security.odbcuserpopulationimpl.searchidentities
        saw.security.userpopulationmanagerimpl.getaccountdetailsbyid
        saw.subsystem.catalog.repaircatalogsecurity
        saw.subsystem.catalog.initialize
        saw.subsystems.catalogbootstrapper.loadcatalog
        saw.webextensionbase.init
        saw.sawserver
ecid:  
]]
+
<10.07.2012 11:03:32 MSD> <Error> <oracle.bi.security.service> <OBI-SEC-00028> <System user could not be authenticated
oracle.bi.security.service.SecurityServiceException: SecurityService::authenticateUserWithLanguage [OBI-SEC-00020] Authenticated user has an invalid GUID



Есть предположение что проблема в том что OVD провайдер не содержит данных о guid.
т.е при просмотре через ldap browser пользователя BISystemUser видим:
objectGUID: Invalid GUID
objectSid: Invalid SID


Возможно необходимо установить какой-то плагин в OVD на AD адаптер.


Комментарии

Популярные сообщения из этого блога

Oracle SOA email notification или какого х.. оно не работает.

От делать нех задокументируем.... Вообщем то всё рассписанно по ссылке: http://www.rubiconred.com/blog/email-notification-with-soa-suite-11g/ Ссылка походу сдохла!!! Придётся на всякий случай записать пока не забыл... Собственно основные настройки делаются на этой странице: Тут будет текст дабы не плодить картинок: MailAccessProtocol : POP3 RetryLimit : -1 MailDelFreq : 600 AutoDelete : not check Debug : not check CheckMailFreq : 30 ReceiveFolder: INBOX OutgoingMailServer :  mail4.ru OutgoingMailServerPort : 25 OutgoingMailServerSecurity : None OutgoingDefaultFromAddr :  pklmn@mail.ru OutgoingPassword: вроде ни чё не трогал... IncomingMailServer: mail3.ru IncomingMailServerPort: 110 IncomingMailServerSSL: not check IncomingMailIDs: pklmn@mail.ru IncomingUserIDs: pklmn IncomingUserPasswords: тут настраиваем пароль При настройке рекомендуется обращать внимания на всплывающие подсказки например: Sender Address должен выглядеть как E...

Weblogic Diagnostic Framework Run Bash Script (reboot managed server) - (bad practices)

Вообщем переодически сервер дохнет по: The WebLogic Server encountered a critical failure java.lang.OutOfMemoryError: Metaspace Reason: There is a panic condition in the server. The server is configured to exit on panic И хотя это гавно пишет типа  Reason: There is a panic condition in the server. The server is configured to exit on panic чёт ни хуя он ни куда не exit.... Вообщем т.к разбираться с тем чем он жрётся нет ни времени ни желания (оно обязательно появится)... как вариант можно приделать костыль... костыль будет заключаться в ребуте сервера при возникновении этой ошибки. Что значит для этого надо... Желания и понимание что так жить нельзя, и вообще... Делаем новый модуль называем скажем:  Reboot-OOMMetaSpace Идём в в новый модуль делаем Policy: Называем его OOM-Metaspace и говорит что это Server log: Жмём next в Configuration Policy пишем: log.logMessage.contains('java.lang.OutOfMemoryError: Metaspace'...

Weblogic Kerberos

Weblogic установлен на сервере budwf Домен контролер wcctst.wcc.local Клиентская винда XZ 1. Генерим keytab ktpass -princ HTTP/srv_budwf@WCC.LOCAL -mapuser srv_budwf -kvno 0 -crypto AES128-SHA1 -ptype KRB5_NT_PRINCIPAL -pass lalal_1 -out c:\temp\budwf.keytab Т.е в данном случае principal name в keytab полностью соответствует ожиданиям... C:\Users\Administrator>ktpass -princ HTTP/srv_budwf@WCC.LOCAL -mapuser srv_budwf -kv no 0 -crypto AES128-SHA1 -ptype KRB5_NT_PRINCIPAL -pass lalal_1 -out c:\temp\b udwf.keytab Targeting domain controller: wcctst.wcc.local Successfully mapped HTTP/budwf to srv_budwf. Password succesfully set! Key created. Output keytab to c:\temp\budwf.keytab: Keytab version: 0x502 keysize 55 HTTP/budwf@WCC.LOCAL ptype 1 (KRB5_NT_PRINCIPAL) vno 0 etype 0x11 (AE S128-SHA1) keylength 16 (0xbf005ae14d58153abe3eab57cf5a8260) C:\Users\Administrator>setspn -L srv_budwf Registered ServicePrincipalNames for CN=srv_budwf,CN=Users,DC=wcc,DC=local: ...